Przeniesienie bazy danych

Date 09/05/2007 Category Kategorie: site, wordpress | by Lan Pham

Zaraz szlag mnie trafi.
Znów mam problemy z przeniesieniem bazy danych wordpress’a na inny serwer. Ostatnio gdy próbowałam wystarczyło zimportować w kodowaniu utf8. Takie rzekomo kodowanie ma moja baza.
(rzekomo, albowiem w phpmyadminie na starym serwerze jest “System kodowania znaków dla MySQL: UTF-8 Unicode (utf8)”, a niektóre tabele mają “Metoda porównywania napisów” w latin2 i latin1. To nie to samo, no nie? :F)
Ale tym razem ani w imporcie w utf8, ani w latin2 ani w latin1, nie pojawiają się polskie znaki!

Potrzebuję Waszej pomocy. Poważnie.

Pomocy!

PS: A więc znów mała przerwa w pisaniu.



?

Dobrze idzie, jest 8 komentarzy w “Przeniesienie bazy danych”

  1. # marines :: 09/05/2007 @ 21:31 ::

    a może artykuł Mathew ci pomoże?
    http://blog.mathew-coder.info/index.php?p=7&more=1&c=1

  2. # Lanooz :: 09/05/2007 @ 22:12 ::

    O. Poprobuje w najblizszym czasie. No wreszcie jakas alternatywa wsrod pomocnych linkow.
    Dziekuje :)

  3. # czarna! wyobrażasz sobie?:P :: 10/05/2007 @ 00:15 ::

    huhu a ja się nie znam:)

  4. # Mikoskay :: 10/05/2007 @ 07:53 ::

    Metoda porównywania to inna sprawa. A z różnicą kodowania między bazą a phpMyAdmin to typowa sprawa w dziadowych hostingach. Ja sobie radzę wstawiając bazę z poziomu PHP… Zawsze działa. :)

  5. # koras :: 12/05/2007 @ 00:17 ::

    Kurczę ciężka sprawa. Ja zawsze importowałem po prostu zwracając tylko uwagę na metodę porównywania i to nic, że było to latin1 ze szwedzkimi znakami, wszystkie bazy w utf-8 pełne polskich ogonków i tak zaimportowałem.
    Bałem się tego, ale nie miałem wyjścia. Wierzę Lan, że ci się uda;)
    Kiedyś też histeryzowałem i nic nie mogłem poradzić na brak polskich znaków, a problem rozwiązał się sam, przypadkowo jak patrzyłem sobie na różne funkcje panelu phpMyAdmina.
    Spróbuj importować ustawiając takie samo kodowanie co jest metoda porównywania wpisów i musi Ci się udać. Wierzę w ciebie;P

  6. # Cezary Okupski :: 17/05/2007 @ 19:52 ::

    Spróbuj dopisać przed wszystkimi zapytaniami do bazy SET NAMES UTF8;.

  7. # piotrinet :: 18/05/2007 @ 12:40 ::

    Witam, też niedawno się męczyłem strasznie z bazą, przenosiłem mój katalog Hostings – jakieś 2 dni. Zrobiłem to tak:
    – eksport starej bazy z phpMyAdmina
    – z poziomu administracji wordpressa jest opcja eksportuj do XML wiadomości, zapisujesz sobie gdzieś tego XMLa,
    – instalujesz od nowa wordpressa na nowym serwerze
    – importuj tabele z kategoriami, użytkownikami i innymi oprócz postów
    – posty importuj z poziomu administracji nowego wordpressa
    – i gotowe

    Ewentualnie sam import postów z XMLa odbuduje bazę użytkowników, nie pamiętam już jakm było dokłdnie, ale spróbuj tego sposobu.
    Powodzenia

  8. # Lanooz :: 18/05/2007 @ 13:04 ::

    Nie chcę korzystać z importu wordpressa, ponieważ nie zważa on na kolejność ID wpisów i uporządkowuje je jak leci. A na moim blogu ID są troche poprzestawiane.
    Jednakże dziękuje za sugestię.

    @Cezary Okupski:
    w najblizszym czasie spróbuje Twój sposób, jak i inne powyzsze. Dziękuje :)

Komentarze zamknięte.